Simon Josefsson simon@josefsson.org writes:
I don't like it -- as far as I recall, DJB calls the ciphers Salsa20 and ChaCha respectively. When round-specific counts are introduced, the naming is Salsa20/R and ChaChaR respectively.
That's my understanding too.
I don't think it is good to move away from the "upstream" naming scheme for a cipher, even if the naming scheme isn't consistent between ciphers.
I think I agree.
Alternatively, 'salsa20_128_set_key'. I think I prefer one of these variants the most.
I think it will be
void salsa20_128_set_key(struct salsa20_ctx *ctx, const uint8_t *key); void salsa20_256_set_key(struct salsa20_ctx *ctx, const uint8_t *key);
void salsa20_set_key(struct salsa20_ctx *ctx, size_t length, const uint8_t *key);
then.
Regards, /Niels