These functions are somewhat misnamed anyway (they convert to UTF-16 byte streams), and you can always explicitly manipulate UTF-16 using the Charset.encoder/decoder functions. UTF-8 is far more common, and the corresponding string_to_utf8/utf8_to_string functions are more usefully named too.
Is Pike 8.0 a good time to drop string_to_unicode() and unicode_to_string()?
ChrisA