These functions are somewhat misnamed anyway (they convert to UTF-16 byte streams), and you can always explicitly manipulate UTF-16 using the Charset.encoder/decoder functions. UTF-8 is far more common, and the corresponding string_to_utf8/utf8_to_string functions are more usefully named too.
Is Pike 8.0 a good time to drop string_to_unicode() and unicode_to_string()?
ChrisA
No. Nothing gets dropped from 8.0 at this point. If they should be dropped in the future we could still potentially mark them as depricated in 8.0.
I'm not sure I understand your objection to them though. Is it just that they are redundant?
On 12/12/14 10:55, Peter Bortas @ Pike developers forum wrote:
No. Nothing gets dropped from 8.0 at this point. If they should be dropped in the future we could still potentially mark them as depricated in 8.0.
I'm not sure I understand your objection to them though. Is it just that they are redundant?
I think its just that the name is confusing and I would agree to that. I am not sure if it needs to be an efun, maybe there is some windows code that needs it before dynamic modules can be loaded?
Arne
I don't want any API changes to 8.0 at this point. I'm ok with deprecating them for 8.1.
I think, if we can all agree that the name is confusing, we should rename it (string_to_utf16 ?) and deprecate the old symbol. Then, in the next stable release it could be removed. When deprecating something compat support needs to be added for previous versions. The Charset module also uses string_to_unicode internally, but I guess it would be possible to move it there.
We had some discussion about development policy during the meeting on the weekend. The intention was to agree on how and in which branches features are removed, APIs made incompatible and new features get added. Bill has the text and will probably make it public soon. The idea is to have a set of guidelines that everyone tries to stick to that make it easier to prepare a stable releases more often.
Arne
On 12/12/14 06:30, Chris Angelico wrote:
These functions are somewhat misnamed anyway (they convert to UTF-16 byte streams), and you can always explicitly manipulate UTF-16 using the Charset.encoder/decoder functions. UTF-8 is far more common, and the corresponding string_to_utf8/utf8_to_string functions are more usefully named too.
Is Pike 8.0 a good time to drop string_to_unicode() and unicode_to_string()?
ChrisA
pike-devel@lists.lysator.liu.se