enough is enough! i've had it!
with pike: calendar failing, floatingpoint bugs, blocking i/o callbacks upgrading woes
with caudium: php problems parser bugs entity problems licensing problems camas problems
with roxen: mysql dependancy complex rxml classes
with sTeam: confusing web interface problems with access to pike lack of good search facility complicated irc access complex xslt for webpages. supports to many protocols
time to switch!
to python: negative indices in arrays clear indenting syntax no more braces and brakets
to apache: excellent php support no more rxml bussinessfriendly license plenty of webmailers to choose from
to zope: cool leaders (hi paul) instant and easy websites. large user community.
it was a fun ride and i enjoyed working with all of you, but now it's time to move on.
greetings, martin.
Oh, yes, them weeds are much greener on the dark side. ;-)
/ Johan Sundström (folkskådare)
Previous text:
2003-04-01 06:21: Subject: ... and thanks for all the fish
enough is enough! i've had it!
with pike: calendar failing, floatingpoint bugs, blocking i/o callbacks upgrading woes
with caudium: php problems parser bugs entity problems licensing problems camas problems
with roxen: mysql dependancy complex rxml classes
with sTeam: confusing web interface problems with access to pike lack of good search facility complicated irc access complex xslt for webpages. supports to many protocols
time to switch!
to python: negative indices in arrays clear indenting syntax no more braces and brakets
to apache: excellent php support no more rxml bussinessfriendly license plenty of webmailers to choose from
to zope: cool leaders (hi paul) instant and easy websites. large user community.
it was a fun ride and i enjoyed working with all of you, but now it's time to move on.
greetings, martin.
interested in doing python programming, zope/python training, zope/python and/or unix system administration anywhere in the world. -- junior python working in europe csl-gmbh.net programmer zope.org (www.archlab|(www|db).hb2).tuwien.ac.at unix bahai.or.at iaeste.(tuwien.ac|or).at systemadministrator (stuts|black.linux-m68k).org is.(schon.org|root.at) Martin Bähr http://www.iaeste.or.at/~mbaehr/
/ Brevbäraren
On Tue, Apr 01, 2003 at 09:05:03AM +0200, Johan Sundström (folkskådare) @ Pike (-) developers forum wrote:
Oh, yes, them weeds are much greener on the dark side. ;-)
and so much tastier too. :-)
read more responses on: http://www.iaeste.at/~mbaehr/switch.html
greetings, martin.
:-)
negative indices in arrays
Negative indices in arrays sounds horrible. Wasn't it in (some) Pascal or something you could decide what indices your array had?
Array my_array[1..4]={1,2,3,4}; Array my_array[0..3]={1,2,3,4}; Array my_array[-1..2]={1,2,3,4};
Although it could be a nice, truly obfuscating feature. :-)
/ Mirar
Previous text:
2003-04-01 06:21: Subject: ... and thanks for all the fish
enough is enough! i've had it!
with pike: calendar failing, floatingpoint bugs, blocking i/o callbacks upgrading woes
with caudium: php problems parser bugs entity problems licensing problems camas problems
with roxen: mysql dependancy complex rxml classes
with sTeam: confusing web interface problems with access to pike lack of good search facility complicated irc access complex xslt for webpages. supports to many protocols
time to switch!
to python: negative indices in arrays clear indenting syntax no more braces and brakets
to apache: excellent php support no more rxml bussinessfriendly license plenty of webmailers to choose from
to zope: cool leaders (hi paul) instant and easy websites. large user community.
it was a fun ride and i enjoyed working with all of you, but now it's time to move on.
greetings, martin.
interested in doing python programming, zope/python training, zope/python and/or unix system administration anywhere in the world. -- junior python working in europe csl-gmbh.net programmer zope.org (www.archlab|(www|db).hb2).tuwien.ac.at unix bahai.or.at iaeste.(tuwien.ac|or).at systemadministrator (stuts|black.linux-m68k).org is.(schon.org|root.at) Martin Bähr http://www.iaeste.or.at/~mbaehr/
/ Brevbäraren
I think he rather means:
array a = allocate(10); a = a[..-3];
or so.
/ David Hedbor
Previous text:
2003-04-02 08:12: Subject: ... and thanks for all the fish
:-)
negative indices in arrays
Negative indices in arrays sounds horrible. Wasn't it in (some) Pascal or something you could decide what indices your array had?
Array my_array[1..4]={1,2,3,4}; Array my_array[0..3]={1,2,3,4}; Array my_array[-1..2]={1,2,3,4};
Although it could be a nice, truly obfuscating feature. :-)
/ Mirar
Array my_array[0..3]={1,2,3,4}; Array my_array[-1..2]={1,2,3,4}; Although it could be a nice, truly obfuscating feature. :-)
Not that I advocate these sort of array intervalls, but...
Remember that Pascal was carried a *lot* of weight around mathematicians and for what it's worth - the ability of using negative indexing really helped students with a mathematical background.
Another great(!) and wounderfull feature was the 'in' operator in Pascal that allowed you to write
If 2 In my_array Then Begin ... End;
IIRC. I think these sort of natural constructs, in a human perspective, that really allowed Pascal to have such a huge user base.
Then again, I still get a warm fuzzy feeling inside when I see pascal code.
Hmm.. come to think of it, I don't think this was what Martin meant.
/ Peter Lundqvist (disjunkt)
Previous text:
2003-04-02 08:12: Subject: ... and thanks for all the fish
:-)
negative indices in arrays
Negative indices in arrays sounds horrible. Wasn't it in (some) Pascal or something you could decide what indices your array had?
Array my_array[1..4]={1,2,3,4}; Array my_array[0..3]={1,2,3,4}; Array my_array[-1..2]={1,2,3,4};
Although it could be a nice, truly obfuscating feature. :-)
/ Mirar
The `in' operator is rather useful actually, and guess what, Pike has it already! It's the index operator on multisets. (The Pascal `in' operator operated only on sets, not arrays, AFAICR.)
/ Marcus Comstedt (ACROSS) (Hail Ilpalazzo!)
Previous text:
2003-04-02 12:04: Subject: ... and thanks for all the fish
Array my_array[0..3]={1,2,3,4}; Array my_array[-1..2]={1,2,3,4}; Although it could be a nice, truly obfuscating feature. :-)
Not that I advocate these sort of array intervalls, but...
Remember that Pascal was carried a *lot* of weight around mathematicians and for what it's worth - the ability of using negative indexing really helped students with a mathematical background.
Another great(!) and wounderfull feature was the 'in' operator in Pascal that allowed you to write
If 2 In my_array Then Begin ... End;
IIRC. I think these sort of natural constructs, in a human perspective, that really allowed Pascal to have such a huge user base.
Then again, I still get a warm fuzzy feeling inside when I see pascal code.
Hmm.. come to think of it, I don't think this was what Martin meant.
/ Peter Lundqvist (disjunkt)
Well..
if 2 in my_set then (* some code *)
still is far easier to understand without previous coding experience compared to
if(my_set[2]) /*some code*/
I'm not too sure about 'in' only working on sets, but that may verry well be something that has changed over the eons... =)
/ Peter Lundqvist (disjunkt)
Previous text:
2003-04-02 12:17: Subject: ... and thanks for all the fish
The `in' operator is rather useful actually, and guess what, Pike has it already! It's the index operator on multisets. (The Pascal `in' operator operated only on sets, not arrays, AFAICR.)
/ Marcus Comstedt (ACROSS) (Hail Ilpalazzo!)
Yeah, and begin/end is easier than { and }. Or is it? :)
/ David Hedbor
Previous text:
2003-04-02 12:53: Subject: ... and thanks for all the fish
Well..
if 2 in my_set then (* some code *)
still is far easier to understand without previous coding experience compared to
if(my_set[2]) /*some code*/
I'm not too sure about 'in' only working on sets, but that may verry well be something that has changed over the eons... =)
/ Peter Lundqvist (disjunkt)
It's easier to read for a novice. It certainly is annoying to write. OTOH I used to be pretty darn fast at typing begin/end/procedure/function...
/ Peter Lundqvist (disjunkt)
Previous text:
2003-04-02 19:52: Subject: ... and thanks for all the fish
Yeah, and begin/end is easier than { and }. Or is it? :)
/ David Hedbor
I'll veto everything that increases "easy to learn" at the cost of "easy to use".
/ Martin Nilsson (har bott i google)
Previous text:
2003-04-02 23:49: Subject: ... and thanks for all the fish
It's easier to read for a novice. It certainly is annoying to write. OTOH I used to be pretty darn fast at typing begin/end/procedure/function...
/ Peter Lundqvist (disjunkt)
Even history? Keep in mind that what was beeing discussed was not pike, but pascal.
/ Peter Lundqvist (disjunkt)
Previous text:
2003-04-03 00:17: Subject: ... and thanks for all the fish
I'll veto everything that increases "easy to learn" at the cost of "easy to use".
/ Martin Nilsson (har bott i google)
Yes, history was clearly in the wrong when it came up with pascal. There is need for some revision. :-)
/ Peter Bortas
Previous text:
2003-04-03 00:46: Subject: ... and thanks for all the fish
Even history? Keep in mind that what was beeing discussed was not pike, but pascal.
/ Peter Lundqvist (disjunkt)
Yeah, and if(foo AND bar) is easier to read than if(foo && bar) for someone that doesn't know programming.
This is a programming language that's easy for beginner programmers as well as easy / powerful for advanced programmers. However it's not a teaching language or a language meant for non-technical people.
/ David Hedbor
Previous text:
2003-04-02 23:49: Subject: ... and thanks for all the fish
It's easier to read for a novice. It certainly is annoying to write. OTOH I used to be pretty darn fast at typing begin/end/procedure/function...
/ Peter Lundqvist (disjunkt)
well, i was actually refering to ranges, which we had discussed recently.
greetings, martin.
pike-devel@lists.lysator.liu.se