Note the difference to this:
arr[ ..< 1] == arr[ ..sizeof(arr)-2] arr[ ..< 0] == arr[ ..sizeof(arr)-1] arr[ ..<-1] == arr[ ..sizeof(arr)+0] arr[ ..<-2] == arr[ ..sizeof(arr)+1]
On the other hand, I don't think it matters much as long as it's defined. But to be consistent with arr[-1] the first one might be a tad better.
"a"[0..] == "a"[..<0] seems more cosistent to me.
pike-devel@lists.lysator.liu.se