These functions seems to never have been checked in. Should I do that? Should they be named to_hex/from_hex, or string2hex/hex2string?
/ Niels Möller ()
Previous text:
2002-05-10 22:42: Subject: nettle.cmod
Getting down to the optimal number of classes, and making the best use of the hacks in nettle's nettle-meta.h.
But I may be able to solve the problem in a better way once I get inherit to work. At the moment, my problem is that aes->crypt dies of bus error...
And I've had to hack the String.from_hex and to_hex functions, as the GMP-versions didn't handle leading zeroes right. These are the current definitions. Do they look ok? I thought array_sscanf(s, "%@2x") would work, but appearantly sscanf doesn't support @.
/*! @decl string from_hex(string hex) *! *! Convert a string of hexadecimal digits to binary data. *! *! @seealso *! @[to_hex()] */ string from_hex(string s) { if (sizeof(s) % 2) error("Can't have an odd number of digits.");
return (string)(array_sscanf(s, "%{%2x%}")[0] * ({})); }
/*! @decl string to_hex(string hex) *! *! Convert a string of binary data to hexadecimal digits. *! *! @seealso *! @[from_hex()] */ string to_hex(string s) { return sprintf("%@02x", (array(int)) s); }
/ Niels Möller ()
Crypto.string_to_hex;
Result: string_to_hex
Crypto.hex_to_string;
Result: hex_to_string
/ Henrik Grubbström (Lysator)
Previous text:
2003-03-12 15:18: Subject: nettle.cmod
These functions seems to never have been checked in. Should I do that? Should they be named to_hex/from_hex, or string2hex/hex2string?
/ Niels Möller ()
Those are really functions in _Crypto, and they should be retired (except for backwards compatibility) with _Crypto. And the functions belong in String, not in Crypto.
So what I want is a good name for the fucntions in String.
/ Niels Möller ()
Previous text:
2003-03-12 15:19: Subject: nettle.cmod
Crypto.string_to_hex;
Result: string_to_hex
Crypto.hex_to_string;
Result: hex_to_string
/ Henrik Grubbström (Lysator)
At the moment, I think String.string2hex is more consistent with other functions, in particular String.int2hex. I'm unsure if I should wait for somebody else to agree that is right before checking in. Grubbas comment just made me more confused.
/ Niels Möller ()
Previous text:
2003-03-12 15:18: Subject: nettle.cmod
These functions seems to never have been checked in. Should I do that? Should they be named to_hex/from_hex, or string2hex/hex2string?
/ Niels Möller ()
So, at least a few pike hackers have read this message by now, so I'll interpret the silence as an ok. It's no big deal to change it if anybody objects later.
I'd also like a definite answer on the Nettle / _Nettle question, as it simplifies life to get names of directories in CVS right from the start.
/ Niels Möller ()
Previous text:
2003-03-12 16:38: Subject: nettle.cmod
At the moment, I think String.string2hex is more consistent with other functions, in particular String.int2hex. I'm unsure if I should wait for somebody else to agree that is right before checking in. Grubbas comment just made me more confused.
/ Niels Möller ()
It really depends on your intentions for it. But if you name it _Nettle one could easily create a Pike-level wrapper named Nettle later.
/ Martin Nilsson (har bott i google)
Previous text:
2003-03-12 17:21: Subject: nettle.cmod
So, at least a few pike hackers have read this message by now, so I'll interpret the silence as an ok. It's no big deal to change it if anybody objects later.
I'd also like a definite answer on the Nettle / _Nettle question, as it simplifies life to get names of directories in CVS right from the start.
/ Niels Möller ()
string2hex and hex2string is ok by me. Don't throw an error for uneven lengthed hex strings though. Pad them instead.
/ Martin Nilsson (har bott i google)
Previous text:
2003-03-12 17:21: Subject: nettle.cmod
So, at least a few pike hackers have read this message by now, so I'll interpret the silence as an ok. It's no big deal to change it if anybody objects later.
I'd also like a definite answer on the Nettle / _Nettle question, as it simplifies life to get names of directories in CVS right from the start.
/ Niels Möller ()
In the _beginning_, mind. hex2string("123") should be "\x01\x23", not "\x12\x30".
/ Marcus Comstedt (ACROSS) (Hail Ilpalazzo!)
Previous text:
2003-03-12 17:24: Subject: nettle.cmod
string2hex and hex2string is ok by me. Don't throw an error for uneven lengthed hex strings though. Pad them instead.
/ Martin Nilsson (har bott i google)
I could do padding. Do you have a good reason you want that rather than an error?
I'm writing the testcases now. I'm also not sure how to deal with wide strings in string2hex. I think that should also be treated as an error (unless there's some extra argument saying how many digits per character you want in the output). What's the easiest way for a pike program to signal an error if it gets a string with wide characters?
/ Niels Möller ()
Previous text:
2003-03-12 17:24: Subject: nettle.cmod
string2hex and hex2string is ok by me. Don't throw an error for uneven lengthed hex strings though. Pad them instead.
/ Martin Nilsson (har bott i google)
if(String.width(str)>8) error("Bröl");
/ Martin Nilsson (har bott i google)
Previous text:
2003-03-12 17:28: Subject: nettle.cmod
I could do padding. Do you have a good reason you want that rather than an error?
I'm writing the testcases now. I'm also not sure how to deal with wide strings in string2hex. I think that should also be treated as an error (unless there's some extra argument saying how many digits per character you want in the output). What's the easiest way for a pike program to signal an error if it gets a string with wide characters?
/ Niels Möller ()
string2hex and hex2string is ok by me.
Please, no! String.to_hex and String.from_hex are IMHO much preferred over String.string2hex (perhaps that should be String.sTr1ng2h3ks or something equally 'L337?).
/ David Hedbor
Previous text:
2003-03-12 17:24: Subject: nettle.cmod
string2hex and hex2string is ok by me. Don't throw an error for uneven lengthed hex strings though. Pad them instead.
/ Martin Nilsson (har bott i google)
String.int2roman, String.int2size, String.to_hex Yep, that looks like a coherent set of functions.
/ Martin Nilsson (har bott i google)
Previous text:
2003-03-13 06:03: Subject: nettle.cmod
string2hex and hex2string is ok by me.
Please, no! String.to_hex and String.from_hex are IMHO much preferred over String.string2hex (perhaps that should be String.sTr1ng2h3ks or something equally 'L337?).
/ David Hedbor
how about String.dec2hex and String.hex2dec
since here input and output are always strings, hex2string is not specific since in other functions the content of the string is being descibed.
hex2int would be wrong because int should mean a real integer as it does in String.int2roman() and hex is a representation of an integer.
greetings, martin.
But "dec" is wrong. It's really a conversion between base 256 and base 16. No base 10 in sight. "octets2hex" would be better.
/ Niels Möller ()
Previous text:
2003-03-13 08:03: Subject: Re: nettle.cmod
how about String.dec2hex and String.hex2dec
since here input and output are always strings, hex2string is not specific since in other functions the content of the string is being descibed.
hex2int would be wrong because int should mean a real integer as it does in String.int2roman() and hex is a representation of an integer.
greetings, martin.
/ Brevbäraren
By the way, why not add the corresponding functions for 16 and 32 bit wide strings?
/ Mirar
Previous text:
2003-03-13 08:40: Subject: Re: nettle.cmod
But "dec" is wrong. It's really a conversion between base 256 and base 16. No base 10 in sight. "octets2hex" would be better.
/ Niels Möller ()
I was thinking of adding an optional argument that says how many octets per character you want. Whoever needs that can add it ;-)
/ Niels Möller ()
Previous text:
2003-03-13 08:51: Subject: Re: nettle.cmod
By the way, why not add the corresponding functions for 16 and 32 bit wide strings?
/ Mirar
Then fix int2roman and int2size... I don't think methods name like that should exist in Pike API's.
/ David Hedbor
Previous text:
2003-03-13 06:39: Subject: nettle.cmod
String.int2roman, String.int2size, String.to_hex Yep, that looks like a coherent set of functions.
/ Martin Nilsson (har bott i google)
I'd go with 'Nettle' if I was you.
/ Per Hedbor ()
Previous text:
2003-03-12 17:21: Subject: nettle.cmod
So, at least a few pike hackers have read this message by now, so I'll interpret the silence as an ok. It's no big deal to change it if anybody objects later.
I'd also like a definite answer on the Nettle / _Nettle question, as it simplifies life to get names of directories in CVS right from the start.
/ Niels Möller ()
On A I'll answer sounds good. On B I still think Nettle is good.
string2hex/hex2string sounds excellent since there already are a2b functions in String. I like the from_hex/to_hex better, but it's better to keep the naming convention.
Since Nettle is the final glue, and there is no plans to have a better API then Crypto, I can't see why it wouldn't be an excellent name with "_". Crypto.Nettle would of course be better, if it's possible.
/ Mirar
Previous text:
2003-03-12 17:21: Subject: nettle.cmod
So, at least a few pike hackers have read this message by now, so I'll interpret the silence as an ok. It's no big deal to change it if anybody objects later.
I'd also like a definite answer on the Nettle / _Nettle question, as it simplifies life to get names of directories in CVS right from the start.
/ Niels Möller ()
Ok, now there's a subdirectory post_modules/Nettle. The code is not quite what I want it to be, it's basically the code I wrote a few months ago that is checked in now. At least it compiles and has a basic testsuite.
Bugs: It doesn't have algorithm objects. Names are still lowercase. Most algorithms are missing (I started with md5, sha1 and aes).
/ Niels Möller ()
Previous text:
2003-03-12 17:21: Subject: nettle.cmod
So, at least a few pike hackers have read this message by now, so I'll interpret the silence as an ok. It's no big deal to change it if anybody objects later.
I'd also like a definite answer on the Nettle / _Nettle question, as it simplifies life to get names of directories in CVS right from the start.
/ Niels Möller ()
String.to_hex, String.from_hex (an extra string is redundant and foo2bar is too l33t I think :-)
/ David Hedbor
Previous text:
2003-03-12 16:38: Subject: nettle.cmod
At the moment, I think String.string2hex is more consistent with other functions, in particular String.int2hex. I'm unsure if I should wait for somebody else to agree that is right before checking in. Grubbas comment just made me more confused.
/ Niels Möller ()
pike-devel@lists.lysator.liu.se