Take it from the other viewpoint: What kind of errors do you detect with that warning? I don't see many that is worth that warning.
Warnings about unused function-local variables, though. That catches many errors and they don't fill any function unused.
void remove(string file, int(0..1) dry_run) { werror("Now removing %O\n", file); // if(!dry_run) rm(file); }
Might be somewhat contrived, but leaving unused arguments like this primarily screws up readability when scanning code. When you develop it it's perfectly fine, but if you have moved it to production and start turning on #strict_whatever it time to lean more towards ADA than Perl.
But as I mentioned eariler, it's currently impossible in pike, and it's also impossible in general, to write callback based API:s without having unused arguments. Unless you only want a single mapping or event object as the argument.
Yes, and that's why I said it's not acceptable to have those warnings without some special #pragma.
It's not acceptible with a #pragma either. That's way too clumsy.
I don't think a warning for unused arguments is that useful to begin with; the risk to accidentally miss using an argument is not very high. So if we can't agree on a good way to turn it off on a per-argument basis (I still think leaving out the name is a good way, though) it's better to just leave it unimplemented.
Since you where the champion of the idea we'll happily resolve this without action then.
I tend to agree that most often, unused arguments are harmless. I don't think most java development tools complain about them, whereas most (by default) do complain about unused locals. Perhaps there's opportunity for levels of specificity:
#pragma unused_locals #pragma unused_arguments
?
On May 23, 2008, at 11:25 AM, Martin Stjernholm, Roxen IS @ Pike developers forum wrote:
It's not acceptible with a #pragma either. That's way too clumsy.
I don't think a warning for unused arguments is that useful to begin with; the risk to accidentally miss using an argument is not very high. So if we can't agree on a good way to turn it off on a per-argument basis (I still think leaving out the name is a good way, though) it's better to just leave it unimplemented.
pike-devel@lists.lysator.liu.se