Yes. Some sort of global function corresponding to m_delete for the insert operation will also be necessary for the new multisets. To be consistent it should then be called m_insert, but I don't particularly like the "m_" prefix in this case either. (As it happens, it works for multisets too, but the operation is really more fundamental than that.)
Perhaps we can come up with a new operator syntax instead?
/ Martin Stjernholm, Roxen IS
Previous text:
2002-11-10 11:20: Subject: More about ADTs
It would make some sense to have "delete" be the name of a global function, and "_delete" be the name of the method. I.e.
delete(mixed collection, mixed index) { if (objectp(collection)) return collecction->_delete(index); else if (mappingp(collecction)) return ...; ... }
I guess this is just a new name for the global m_delete function.
/ Niels Möller ()