I changed part of the ASN1 decoder to use IOBuffer. Some comments
- Stdio.IOBuffer is harder to type than ADT.struct. Can we rename it to Stdio.Buffer? There is already IO in Stdio.
- get_ is shorter than read_. I'm on the fence on if this is a good change though.
- read_buffer dosn't return Stdio.IOBuffer.
An expression of type { IOBuffer = object } cannot be assigned to a variable of type { IOBuffer = object(implements _static_modules._Stdio()->IOBuffer) }.
- It would be great if we could type cast() properly, so we can tell that (string)iobuffer is actually string(8bit).