It helps by getting rid of the `, which is if not hard at least harder to type than lfun, at least when you have dead-keys enabled.
Also, the current lfun naming scheme is, as you pointed out, somewhat inconsistent.
I really think that adding some kind of indication of the fact that it's a special function would be a good idea, regardless of whether or not we want a new keyword, thus allowing '_m_delete' to be called '`m_delete' if not 'lfun m_delete'.
And, yes, '_m_delete' and 'lfun m_delete' would be the same thing.
I also suggest something along the lines of
object x; x->lfun::m_delete( ... )
to access the lfuns directly.
/ Per Hedbor ()
Previous text:
2003-04-17 00:44: Subject: Re: Pointers/lvalues
How does that address the obscurity of lfun names like `*, ``* and
I assume Foo lfun m_delete(int x) {} Foo _m_delete(int x) {} would give a duplicate identifier error, at least for the lfuns on that form that already exist. Later on this could be used to separate the namespaces of lfuns and ordinary functions, but that could otoh be accomplished with names on the form `m_delete, `indices etc. (`create instead of create. Hmm, well..) / Martin Stjernholm, Roxen IS