It would make some sense to have "delete" be the name of a global function, and "_delete" be the name of the method. I.e.
delete(mixed collection, mixed index) { if (objectp(collection)) return collecction->_delete(index); else if (mappingp(collecction)) return ...; ... }
I guess this is just a new name for the global m_delete function.
/ Niels Möller ()
Previous text:
2002-11-09 17:39: Subject: More about ADTs
I most definitely think that it would be worse to have two different names for the same function. `[] and `-> is enough.
/ Martin Stjernholm, Roxen IS