void remove(string file, int(0..1) dry_run) { werror("Now removing %O\n", file); // if(!dry_run) rm(file); }
Might be somewhat contrived, but leaving unused arguments like this primarily screws up readability when scanning code. When you develop it it's perfectly fine, but if you have moved it to production and start turning on #strict_whatever it time to lean more towards ADA than Perl.