I would, because it looks more readable than
foreach(Stdio.stdin->read()/"\n", string line)
But that is beside the point that it is the Right Thing to do. Dropping information is not.
/ Peter Bortas
Previous text:
2002-12-31 14:42: Subject: stdin->line_iterator
That's not good enough. If I wanted to suck up a complete file into memory, I wouldn't bother with line_iterator in the first place.
What I need to do is something like
int first = 1; foreach(Stdio.stdin->line_iterator();; string line) { if (first) first = 0; else write("\n");
write(line);
}
which I find way too complex for such a simple task.
/ Niels Möller ()