int foo(int zot=17) is shorter and more readable than the equivalent
int foo(int|void zot) { if(zero_type(zot)) zot = 17; }
/ Johan Sundström (folkskådare)
Previous text:
2003-03-06 14:10: Subject: Re: negative indices in array ranges
On Thu, Mar 06, 2003 at 01:15:05PM +0100, Mirar @ Pike developers forum wrote:
int foo(int|void zot=17)
how is that different from:
int foo(int|void zot) { if (!zot) zot=17; }
greetings, martin.
/ Brevbäraren