How does that address the obscurity of lfun names like `*, ``* and ```*?
I assume
Foo lfun m_delete(int x) {} Foo _m_delete(int x) {}
would give a duplicate identifier error, at least for the lfuns on that form that already exist.
Later on this could be used to separate the namespaces of lfuns and ordinary functions, but that could otoh be accomplished with names on the form `m_delete, `indices etc. (`create instead of create. Hmm, well..)
/ Martin Stjernholm, Roxen IS
Previous text:
2003-04-16 18:51: Subject: Re: Pointers/lvalues
How about lfun as a prefix? Not only for the new ones, then, but as an alternative to ´ in general:
class Foo { Foo lfun +(int x) { // or lfun::+? }
Foo lfun ´+(int x) { // (``+), perhapos +', as in +-2. :-) }
Foo lfun m_delete(int x) { // as in _m_delete } }
Or perhaps 'operator', but that would be somewhat misleading in pike.
class Foo { Foo operator *(int x) { }
Foo operator m_delete(int x) { } }
/ Per Hedbor ()