SHA is the name most people would guess. The documentation says it is SHA1.
I'm not so sure about that. And if we ever need to implement the original "SHA" function, what should that be named? (Google yields 209 000 hits for "sha1 hash", and only 84 500 for "sha hash", using "all of the words"-queries).
Yes, I tried Nettle.Buffer first, but it doesn't work (some sort of name collision I think).
Odd. No idea what it collided with?
Perhaps it should be renamed, and perhaps it would make sense with a feed/drain interface.
But on second thought, feed/drain might need an arbitrary large buffer. The current convention (if I understand it correctly) never needs to save more than one block of data. Which is nice from an implementation point of few, in particular as the implementation is written in C.
There are also a few different conventions for padding, so I hope the class can be extended easily.
/ Niels Möller (vässar rödpennan)
Previous text:
2004-02-04 21:21: Subject: Crypto naming
I think Crypto.SHA ought to be renamed Crypto.SHA1.
SHA is the name most people would guess. The documentation says it is SHA1.
The name Crypto.Proxy is somewhat strange (it's actually a buffer).
Yes, I tried Nettle.Buffer first, but it doesn't work (some sort of name collision I think). But it is of course simple to rename it in Crypto.pmod so that we get Crypto.Buffer.
Perhaps it should be renamed, and perhaps it would make sense with a feed/drain interface.
Add it if you like.
Also the pad method looks a little strange,
That code is copied from _Crypto.crypto. It does look fishy...
/ Martin Nilsson (saturator)