Time for an lsh release

Niels Möller nisse at lysator.liu.se
Mon Nov 30 19:29:19 CET 2015


[Resend, first attempt wasn't sent to the list]

ludo at gnu.org (Ludovic Courtès) writes:

> I think this is one of the things urgently needed if we want to allow
> people to keep using lsh/lshd, along with applying the Nettle 3 upgrade
> patch².

I agree an lsh-2.2 update is needed. There are also compilation problems
with the argp subdir and gcc-5, due to the changed inline semantics.

For nettle-3 and lsh-2.x, I'm considering doing the nettle3 update using
dsa-compat.h instead, like in
https://sources.debian.net/src/lsh-utils/2.1-7/debian/patches/nettle3.patch/

Unfortunately, I don't have too much hacking time, and I also have a
Nettle release due soon. Co-maintainers welcome.

I have filed the paperwork needed to get my employer (since a few weeks
back I'm at google, Stockholm) to disclaim copyright interest in lsh
development I do. I already have a similar clearance for Nettle.

Regards,
/Niels

-- 
Niels Möller. PGP-encrypted email is preferred. Keyid C0B98E26.
Internet email is subject to wholesale government surveillance.


More information about the lsh-bugs mailing list