[Mattricks] mattricks problems with fedora core 2 linux

Zazell Kroeske slkroesk at chello.nl
Tue Sep 14 12:08:50 CEST 2004


I have Mattricks working under FC2, it took me quite some work, but it
came down to the point that you should run mattricks usings
/usr/bin/python2 instead of /usr/bin/python don't know for sure if that
was all.

this is the list of python related packages i have installed:

gnome-python2-canvas.i386 0:2.0.0-4.1
python.i386 0:2.3.3-6
rpm-python.i386 0:4.3.1-0.3_27.rhfc2.at
wxpythongtk.i386 0:2.4.2.4-1.rhfc2.nr
python-optik.noarch 0:1.4.1-5
PyXML.i386 0:0.8.3-4.1
gnome-python2-gtkhtml2.i386 0:2.0.0-4.1
gnome-python2.i386 0:2.0.0-4.1
gnome-python2-gconf.i386 0:2.0.0-4.1
rhpl.i386 0:0.143-1 
mod_python.i386 0:3.1.3-1.fc2.1 
libxml2-python.i386 0:2.6.10-2_11.rhfc2.at 
gnome-python2-bonobo.i386 0:2.0.0-4.1 
pyparted.i386 0:1.6.6-2 
python-bsddb3.i386 0:4.2.4-1.1.fc2.dag 
python-devel.i386 0:2.3.3-6  

Zazell


On Tue, 2004-09-14 at 11:06, Peter Peltonen wrote:
> I downloaded the Mattricks-0.6-1.noarch.rpm and 
> wxPythonGTK2-py2.3-2.5.2.8-FC2.i386.rpm from http://wxPython.org and 
> installed the packages with `rpm -ivh` which went fine.
> 
> My problem is that when I try to launch the problem I get the following 
> error and the program won't run:
> 
> --<snip>--
> [peter at bahama peter]$ mattricks.py
> /usr/lib/python2.3/site-packages/Mattricks/Main.py:206: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    sizer.AddSizer(hsizer, 0, wxEXPAND | wxBOTTOM, 0)
> /usr/lib/python2.3/site-packages/Mattricks/AboutPage.py:123: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    sizer.AddSizer(flag_sizer, 0, wxEXPAND | wxALIGN_CENTRE | wxALL, 2)
> /usr/lib/python2.3/site-packages/Mattricks/AboutPage.py:90: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    inside_sizer.AddSizer(tsizer, 0, wxEXPAND | wxALIGN_CENTRE | wxALL, 2)
> /usr/lib/python2.3/site-packages/Mattricks/AboutPage.py:100: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    hsizer.AddSizer(inside_sizer, 1, wxEXPAND | wxALIGN_CENTRE | wxALL, 2)
> /usr/lib/python2.3/site-packages/Mattricks/AboutPage.py:104: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    main_sizer.AddSizer(hsizer, 1, wxEXPAND | wxALIGN_CENTRE | wxALL, 2)
> /usr/lib/python2.3/site-packages/Mattricks/SummaryPage.py:54: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    sizer.AddSizer(hsizer, 0, wxEXPAND | wxALIGN_CENTRE | wxALL, 0)
> /usr/lib/python2.3/site-packages/Mattricks/SummaryPage.py:93: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    hsizer2.AddSizer(fsizer, 1, wxEXPAND | wxALIGN_CENTRE | wxALL, 0)
> /usr/lib/python2.3/site-packages/Mattricks/SummaryPage.py:96: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    sizer.AddSizer(hsizer2, 1, wxEXPAND | wxALIGN_CENTRE | wxALL, 0)
> /usr/lib/python2.3/site-packages/Mattricks/Playerlist.py:362: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    hsizer.AddSizer(vsizer, 0, wxEXPAND | wxALIGN_CENTRE | wxALL, 0)
> /usr/lib/python2.3/site-packages/Mattricks/Playerlist.py:388: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    vsizer.AddSizer(csizer, 0, wxALIGN_RIGHT | wxALL, 0)
> /usr/lib/python2.3/site-packages/Mattricks/Playerlist.py:389: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    hsizer.AddSizer(vsizer, 1, wxEXPAND | wxALIGN_CENTRE | wxALL, 0)
> /usr/lib/python2.3/site-packages/Mattricks/Playerlist.py:391: 
> DeprecationWarning: AddSizer is deprecated, use `Add` instead.
>    sizer.AddSizer(hsizer, 0, wxEXPAND | wxALIGN_CENTRE | wxALL, 0)
> Traceback (most recent call last):
> --</snip>--
> 
> What can I do to make the program run? Here is a list of all packages 
> that have python in their name that I have installed, if it is any 
> relevance:
> 
>    gnome-python2-canvas-2.0.0-4.1
>    rpm404-python-4.0.4-8x.27
>    python-optik-1.4.1-5
>    gnome-python2-gtkhtml2-2.0.0-4.1
>    gnome-python2-2.0.0-4.1
>    libxml2-python-2.6.10-2_11.rhfc2.at
>    mod_python-3.1.3-1.fc2.1
>    python-2.3.3-6
>    gnome-python2-bonobo-2.0.0-4.1
>    python-tools-2.3.3-6
>    rpm-python-4.3.1-0.3_27.rhfc2.at
>    python-devel-2.3.3-6
> 
> If Mattricks does not run under FC2, is there any other programs for 
> Hattrick that work under Linux?
> 
> Regards,
> Peter
> _______________________________________________
> Mattricks mailing list
> Mattricks at lists.lysator.liu.se
> http://lists.lysator.liu.se/mailman/listinfo/mattricks




More information about the Mattricks mailing list